question

Submitted by Lori S. on Sat, 03/12/2011 - 12:13

Here is a question for our computer experts (and an easy one I imagine)...
Occasionally, I add a link to a site that has a very long address, and for some reason, the link will not necessarily "wrap". It will instead, extend off in one line, so that one has to scroll to see it all. This causes the entire screen to widen, with a scroll bar at the bottom. I added such a link this morning...
How does one make the link "wrap" without actually breaking the link?
Thanks,
Lori

Comments


Submitted by Mark McD on Sat, 03/12/2011 - 12:31

Skulski wrote:

Here is a question for our computer experts (and an easy one I imagine)...
Occasionally, I add a link to a site that has a very long address, and for some reason, the link will not necessarily "wrap".  It will instead, extend off in one line, so that one has to scroll to see it all.  This causes the entire screen to widen, with a scroll bar at the bottom.  I added such a link this morning...
How does one make the link "wrap" without actually breaking the link?
Thanks,
Lori

In the case where URLs are too long (an IPNI search is a good example of mile-long URLs), use the Insert Hyperlink tool button (4th one over from the left, looks like an earth globe)... it automaticaly places some code before and after your cursor location, then paste the long url between the code syntax.  It uses the url and /url syntax (within braces [ ]) before and after the url.  Here's my example:

http://www.ipni.org/ipni/advPlantNameSearch.do?find_family=&find_genus=Androsace&find_species=*&find_infrafamily=&find_infragenus=&find_infraspecies=&find_authorAbbrev=&find_includePublicationAuthors=on&find_includePublicationAuthors=off&find_includeBasionymAuthors=on&find_includeBasionymAuthors=off&find_publicationTitle=&find_isAPNIRecord=on&find_isAPNIRecord=false&find_isGCIRecord=on&find_isGCIRecord=false&find_isIKRecord=on&find_isIKRecord=false&find_rankToReturn=all&output_format=normal&find_sortByFamily=on&find_sortByFamily=off&query_type=by_query&back_page=plantsearch

Found an interesting bug yesterday, a condition where a URL will not automatically be detected by the forum to become "live".  If you add some text formatting code in front of a url (I added some bullet numbers and colored them yellow), but placing even a short url after that little bit of formatted text prevented the URL from being live.  So I just added the Insert Hyperlink code to fix it.


Submitted by Lori S. on Sat, 03/12/2011 - 16:25

Sorry, I am not getting this! 
It's in the 'Extreme Silene' thread.  I keep trying to use the URL thingie with closed brackets before and after, but I'm doing something wrong.  Help!
Lori 


Submitted by Mark McD on Sat, 03/12/2011 - 16:58

Lori, are you talking about the Silene syreitschikowii link you gave near the end of the Extreme Silene thread?  The link seems to work for me, unless... is it taking us to a different page than you intend?  I do see that the right "end bracket" on the opening url statement gets automatically taken off for some reason... is that the problem?


Submitted by Lori S. on Sat, 03/12/2011 - 17:27

Well, I don't know what exactly I goofed up... when I open any screen that includes that posting (e.g. Recent Postings), I get the text running off the screen to the left right, and a scroll bar at the bottom.  
Is it only me who sees this?


Submitted by Mark McD on Sat, 03/12/2011 - 17:54

So, when you're in edit mode on that message, the URL goes way out to right and off-screen, and doesn't word-wrap on it's own?  It seems to look just fine to me, even in edit mode.  I wonder if you need to make the "compatibility setting"...
http://nargs.org/smf/index.php?topic=87.0

What browser are you using?  If you look at that same message in a different browser, do you have the same problem?


Submitted by Lori S. on Sat, 03/12/2011 - 20:17

Well, to correct myself, the page on which the original posting (with the extremely long, un-wrapped URL) was, shows up as a very wide page that extends off to the right.  The other pages are normal... and so long as I haven't screwed it up in everyone else's view, I guess it's okay.

I use Safari (I have a Mac).  I've just checked it in Firefox and it looks normal there, by contrast.  The "compatibility setting" seems to apply to Explorer/Windows/PCs, I assume.
Thanks,
Lori